View Issue Details

IDProjectCategoryView StatusLast Update
0000126AlmaLinux-8systemdpublic2021-10-18 12:33
Reporterolahaye74 Assigned Tosfokin  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Summary0000126: bootctl install --path=/boot/etc installs menu entries in /boot/loader/entries instead of /boot/efi/loader/entries
Descriptionbootctl install --path=/boot/etc installs menu entries in /boot/loader/entries instead of /boot/efi/loader/entries
Thus, at boot, the loader finds no entries.

Furthermore, the vmlinuz* and initramfs* are not copied to /boot/efi, the the loader can't find them.
Steps To Reproducebootctl install --path=/boot/etc

expected result : entries are in/boot/efi/loader/entries/ and vmlinuz* and initrd* are copied to EFI partition

actual (bad) result: entries are in /boot/loader/entries/ and initramfs and vmlinuz files are not on EFI system partition.

TagsNo tags attached.
abrt_hash
URL

Activities

sfokin

2021-09-16 10:44

developer   ~0000332

Hi. I use dest path /boot/efi and I have this result:

# bootctl install --path=/boot/efi
Created "/boot/efi/EFI/systemd".
Created "/boot/efi/loader".
Created "/boot/efi/loader/entries".
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/boot/efi/EFI/systemd/systemd-bootx64.efi".
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/boot/efi/EFI/BOOT/BOOTX64.EFI".
Created EFI boot entry "Linux Boot Manager".

===============

# ls -lR /boot/efi
/boot/efi:
total 8
drwx------. 6 root root 4096 210916_06:35:16 EFI
drwx------. 3 root root 4096 210916_06:35:16 loader

/boot/efi/EFI:
total 16
drwx------. 2 root root 4096 210916_06:35:16 BOOT
drwx------. 3 root root 4096 210713_08:07:14 almalinux
drwx------. 2 root root 4096 210713_08:04:58 centos
drwx------. 2 root root 4096 210916_06:35:16 systemd

/boot/efi/EFI/BOOT:
total 180
-rwx------. 1 root root 87426 210810_17:18:46 BOOTX64.EFI
-rwx------. 1 root root 90296 210520_10:43:30 fbx64.efi

/boot/efi/EFI/almalinux:
total 4896
drwx------. 2 root root 4096 210416_09:15:04 fonts
-rwx------. 1 root root 122 210520_10:43:30 BOOTX64.CSV
-rwx------. 1 root root 6572 210713_08:07:14 grub.cfg
-rwx------. 1 root root 1024 210916_06:03:24 grubenv
-rwx------. 1 root root 2286400 210416_09:15:04 grubx64.efi
-rwx------. 1 root root 850232 210520_10:43:30 mmx64.efi
-rwx------. 1 root root 925424 210520_10:43:30 shimx64.efi
-rwx------. 1 root root 922832 210520_10:43:30 shimx64-almalinux.efi

/boot/efi/EFI/almalinux/fonts:
total 0

/boot/efi/EFI/centos:
total 12
-rwx------. 1 root root 6572 210314_12:26:12 grub.cfg
-rwx------. 1 root root 1024 210314_12:26:10 grubenv

/boot/efi/EFI/systemd:
total 88
-rwx------. 1 root root 87426 210810_17:18:46 systemd-bootx64.efi

/boot/efi/loader:
total 8
drwx------. 2 root root 4096 210916_06:35:16 entries
-rwx------. 1 root root 73 210916_06:35:16 loader.conf

/boot/efi/loader/entries:
total 0

===========

Why you use path '/boot/etc' ? If you expect your loader in /boot/efi may you need to use '/boot/efi' ?
I'm not sure about copying vmlinuz* and initrd* to efi partition but I can be wrong.

olahaye74

2021-09-17 13:08

reporter   ~0000333

/boot/etc is a typo sorry, I use /boot/efi

[[email protected] ~]# bootctl install --path=/boot/efi
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/boot/efi/EFI/systemd/systemd-bootx64.efi".
Copied "/usr/lib/systemd/boot/efi/systemd-bootx64.efi" to "/boot/efi/EFI/BOOT/BOOTX64.EFI".
Created EFI boot entry "Linux Boot Manager".
[[email protected] ~]# find /boot -name \*.conf
/boot/efi/loader/loader.conf
/boot/loader/entries/24521460feb34721ba5fcc47a9731ecf-4.18.0-305.19.1.el8_4.x86_64.conf
/boot/loader/entries/24521460feb34721ba5fcc47a9731ecf-0-rescue.conf

a path /boot/efi/loader/entries exists but stays empty.


[[email protected] ~]# mount |grep /dev/sd
/dev/sda4 on / type xfs (rw,relatime,seclabel,attr2,inode64,logbufs=8,logbsize=32k,noquota)
/dev/sda2 on /boot type xfs (rw,relatime,seclabel,attr2,inode64,logbufs=8,logbsize=32k,noquota)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=winnt,errors=remount-ro)
/dev/sdb1 on /export type xfs (rw,relatime,seclabel,attr2,inode64,logbufs=8,logbsize=32k,noquota)
[[email protected] ~]# cat /etc/fstab
# /etc/fstab
LABEL=root / xfs defaults 1 2
LABEL=swap swap swap defaults 0 0
LABEL=boot /boot xfs defaults 1 2
LABEL=EFI /boot/efi vfat umask=0077,shortname=winnt 0 0
LABEL=export /export xfs defaults 1 2

[[email protected] ~]# blkid
/dev/sda4: LABEL="root" UUID="325f324d-0acc-4dd0-9496-f20417d2b0d1" BLOCK_SIZE="512" TYPE="xfs" PARTUUID="f3142b42-4add-4270-812b-b92d70ae483c"
/dev/sda1: LABEL="EFI" UUID="985B-F66A" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="72552a20-2051-4379-8224-ac9d73fca2d4"
/dev/sda2: LABEL="boot" UUID="d8b57bd1-e202-4668-ae1c-cd021e154905" BLOCK_SIZE="512" TYPE="xfs" PARTUUID="1c45db91-acb9-41e0-b763-09a3739d344c"
/dev/sda3: LABEL="swap" UUID="de864adc-49e2-4b71-9030-74f9c32c2c4d" TYPE="swap" PARTUUID="e7820eea-e8ef-4019-a61c-20e13c90580e"
/dev/sdb1: LABEL="export" UUID="7f473143-f741-4653-8ac8-e3b713ec5c80" BLOCK_SIZE="512" TYPE="xfs" PARTUUID="ddd99658-16e5-49b9-8b99-e2c07189bbeb"

sfokin

2021-09-23 14:14

developer   ~0000334

I posted this bug to Centos Stream.
https://bugzilla.redhat.com/show_bug.cgi?id=2007294

sfokin

2021-10-18 12:33

developer   ~0000354

answer from RHEL:
In rhel8 we do not support systemd-boot since grub2 is the preferred bootloader. Unfortunately, we do not plan to spend any time on this.

Issue History

Date Modified Username Field Change
2021-09-15 12:49 olahaye74 New Issue
2021-09-16 10:44 sfokin Note Added: 0000332
2021-09-16 10:44 sfokin Assigned To => sfokin
2021-09-16 10:44 sfokin Status new => feedback
2021-09-17 13:08 olahaye74 Note Added: 0000333
2021-09-17 13:08 olahaye74 Status feedback => assigned
2021-09-23 14:14 sfokin Note Added: 0000334
2021-10-18 12:33 sfokin Note Added: 0000354
2021-10-18 12:33 sfokin Status assigned => closed
2021-10-18 12:33 sfokin Resolution open => won't fix