View Issue Details

IDProjectCategoryView StatusLast Update
0000098AlmaLinux-8almalinux-releasepublic2021-06-07 10:09
Reporterlinuxbuddy Assigned Toezamriy  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000098: ansible_os_family fact in AlmaLinux 8.4
DescriptionIn AlmaLinux 8.3 the ansible_os_family fact showed RedHat and in 8.4 it shows AlmaLinux

    "ansible_os_family": "RedHat",
    "ansible_distribution_version": "8.3",

    "ansible_os_family": "AlmaLinux",
    "ansible_distribution_version": "8.4",

Is that desired or is it a mistake? it would be important for us to know about our playbooks thanks
Steps To Reproducegathering ansible facts on almalinux host
TagsNo tags attached.
abrt_hash
URL

Activities

ezamriy

2021-06-04 17:42

manager   ~0000256

It doesn't look like AlmaLinux issue. The OS family detection is implemented internally in Ansible, please see this peace of code: https://github.com/ansible/ansible/blob/devel/lib/ansible/module_utils/facts/system/distribution.py#L483.
So, the result will depend on an Ansible version that you are using.

Ansible developers added support for AlmaLinux already (see https://github.com/ansible/ansible/pulls?q=is%3Apr+almalinux+is%3Aclosed) so basically what you need is to update your ansible to the latest stable version.

I've tested it with both latest Fedora 34 and EPEL Ansible packages and Ansible correctly returns "RedHat" in both cases.

What distribution and Ansible version are you using?

linuxbuddy

2021-06-07 09:42

reporter   ~0000258

you're right. It is an Ansible bug and we are using a version of ansible that is too old (2.9.18). After updating Ansible to 2.9.20 everything seems to be ok. You can close the bow.

ezamriy

2021-06-07 10:09

manager   ~0000259

Great! Thank you for letting us know.

Issue History

Date Modified Username Field Change
2021-06-04 15:30 linuxbuddy New Issue
2021-06-04 17:35 ezamriy Assigned To => ezamriy
2021-06-04 17:35 ezamriy Status new => assigned
2021-06-04 17:42 ezamriy Status assigned => feedback
2021-06-04 17:42 ezamriy Note Added: 0000256
2021-06-07 09:42 linuxbuddy Note Added: 0000258
2021-06-07 09:42 linuxbuddy Status feedback => assigned
2021-06-07 10:09 ezamriy Status assigned => closed
2021-06-07 10:09 ezamriy Resolution open => fixed
2021-06-07 10:09 ezamriy Note Added: 0000259