View Issue Details

IDProjectCategoryView StatusLast Update
0000094AlmaLinux-8-OTHERpublic2021-06-04 17:41
Reportermcarrafiello Assigned Toalukoshko  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status assignedResolutionopen 
Platformx86_64OSalmalinuxOS Version8.4
Summary0000094: 8.4 Minimal ISO fails to install when using PCI-DSS security baseline due to missing packages
DescriptionI'm trying out the 8.4 minimal ISO on a HPE server over iLO. The machine, has no networking, and thus, the minimal installation has to pull everything from the ISO image.

When using the PCI:DSS security profile, the installer correctly states it is going to include more packages like openscap & aide. During the installation process, and error is tripped when trying to install those same packages, and if you ignore them, then a more fatal error is tripped when the process seemingly tries to use the openscap program which it previously couldn't install. The installation fails.

I think the root cause is that any "extra packages" which the security baselines need may not be included in the minimal ISO, and on a machine without networking, it makes a mess. So this issue is less of a problem with AlmaLinux or the Anaconda installer, and more about how the ISO is packed up.

I'm a very experienced CentOS user, but I honestly don't know if I have ever tried to install the "minimal" ISO while the machine has absolutely no networking. I'm adapting and using our own [internal] instructions for "setting up CentOS 7 minimal on bare metal" to be used with AlmaLinux 8. It's possible this minimal ISO issue goes all the way up the foodchain to RHEL as well?

-Marc
Steps To ReproduceTry to install AlmaLinux 8.4 on a machine, using the minimal ISO file, without any networking configured at installation. Use the PCI:DSS security profile when configuring the installation.
TagsNo tags attached.
abrt_hash
URL

Activities

alukoshko

2021-06-04 17:41

developer   ~0000255

Hello. Thanks for report.
Minimal ISO includes only BaseOS repo and should only be used for simple minimal installations.
Packages needed for OpenSCAP are in AppStream repo.
You should try with full DVD ISO image to get OpenSCAP working.

I'll add this to known issue.

Issue History

Date Modified Username Field Change
2021-06-02 14:57 mcarrafiello New Issue
2021-06-04 17:31 ezamriy Assigned To => alukoshko
2021-06-04 17:31 ezamriy Status new => assigned
2021-06-04 17:41 alukoshko Note Added: 0000255