View Issue Details

IDProjectCategoryView StatusLast Update
0000072AlmaLinux-8-OTHERpublic2021-06-16 16:32
Reporterfwarnke Assigned Toalukoshko  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7 NUCOSAlmaLinuxOS Version8.3
Summary0000072: CentOS v8 to AlmaLinux v8 upgrade fails to boot UEFI system
DescriptionThe last couple of days when running the - curl -O https://raw.githubusercontent.com/AlmaLinux/almalinux-deploy/master/almalinux-deploy.sh, on an Intel i7 NUC using a Samsung EVO or a Samsung PRO 4TB SSD, configured for UEFI boot (Secure boot disabled), after reboot, the server cannot find the boot drive.

If I install AlmaLinux from scratch, it boots fine.

Today's almalinux-deploy.sh now creates a "System setup" boot menu that runs "fwsetup" which then brings up the server's BIOS configuration.
Steps To ReproduceInstall a vanilla CentOS v8.3 on a server that is using UEFI to boot a 4TB SSD, run the latest almalinux-deploy.sh and reboot.
TagsNo tags attached.
abrt_hash
URL

Activities

fwarnke

2021-04-29 18:13

reporter   ~0000176

The "System setup" boot menu that runs "fwsetup" which then brings up the server's BIOS configuration seems to be a result of left-over UEFI partitions from testing this over and over again. I have cleaned them up and am back to the UEFI/EFI bits not carrying over after deploy.

I did notice that if I press F10 to select devices that the computer can boot from, I have a listing for "CentOS Linux" where if I had installed AlmaLinux from scratch, I should see "AlmaLinux" instead. Is it possible that the boot menu is broken or was not migrated correctly?

alukoshko

2021-05-04 22:03

developer   ~0000179

Hello.
Migration script don't update UEFI boot entries at the moment.
See discussion here: https://github.com/AlmaLinux/almalinux-deploy/issues/31

fwarnke

2021-06-14 13:50

reporter   ~0000275

Looks like the latest almalinux-deploy.sh has fixed the issue with UEFI. It worked on a test system I have.

Thanks for the link alukoshko.

Issue History

Date Modified Username Field Change
2021-04-28 15:08 fwarnke New Issue
2021-04-29 18:13 fwarnke Note Added: 0000176
2021-05-04 22:03 alukoshko Note Added: 0000179
2021-06-14 13:50 fwarnke Note Added: 0000275
2021-06-16 16:32 alukoshko Assigned To => alukoshko
2021-06-16 16:32 alukoshko Status new => closed
2021-06-16 16:32 alukoshko Resolution open => fixed