View Issue Details

IDProjectCategoryView StatusLast Update
0000425AlmaLinux-8linux-firmwarepublic2023-09-28 13:01
Reporteroneuponatime Assigned Toalukoshko  
Status resolvedResolutionfixed 
Summary0000425: AMD Genoa won't boot with latest linux-firmware
DescriptionOS won't boot (blank screen after kernel selection) when using latest linux-firmware version (linux-firmware-20230404-114.git2e92a49f.el8_8.alma.1.noarch) on AMD Genoa CPUs (tested on Lenovo SR635v3).

Downgrading to linux-firmware-20230404-114.git2e92a49f.el8_8.alma.noarch fixes an issue.

I tried upgrading kernel to latest version and it doesn't help. When running latest linux-firmware, OS will only boot if I select rescue image.

I tried booting in debug mode, but there is no info or I'm doing it wrong (I was using

OS: AlmaLinux 8 (upgraded to latest packages)
Hardware: Lenovo SR635v3 with latest stable FW patches
Steps To Reproduce- modern server with AMD Genoa CPU (tested on Lenovo SR635v3)
- upgrade linux-firmware to linux-firmware-20230404-114.git2e92a49f.el8_8.alma.1.noarch
- reboot server
- after grub, there is only blank screen and system hangs
Additional Information# lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 48
On-line CPU(s) list: 0-47
Thread(s) per core: 2
Core(s) per socket: 24
Socket(s): 1
NUMA node(s): 1
Vendor ID: AuthenticAMD
BIOS Vendor ID: Advanced Micro Devices, Inc.
CPU family: 25
Model: 17
Model name: AMD EPYC 9254 24-Core Processor
BIOS Model name: AMD EPYC 9254 24-Core Processor
Stepping: 1
CPU MHz: 2900.000
CPU max MHz: 4151.7568
CPU min MHz: 1500.0000
BogoMIPS: 5790.99
Virtualization: AMD-V
L1d cache: 32K
L1i cache: 32K
L2 cache: 1024K
L3 cache: 32768K
NUMA node0 CPU(s): 0-47
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 pcid sse4_1 sse4_2 x2apic movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb cat_l3 cdp_l3 invpcid_single hw_pstate ssbd mba perfmon_v2 ibrs ibpb stibp vmmcall fsgsbase bmi1 avx2 smep bmi2 erms invpcid cqm rdt_a avx512f avx512dq rdseed adx smap avx512ifma clflushopt clwb avx512cd sha_ni avx512bw avx512vl xsaveopt xsavec xgetbv1 xsaves cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local avx512_bf16 clzero irperf xsaveerptr wbnoinvd amd_ppin cppc arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif v_spec_ctrl avx512vbmi umip pku ospke avx512_vbmi2 gfni vaes vpclmulqdq avx512_vnni avx512_bitalg avx512_vpopcntdq la57 rdpid overflow_recov succor smca fsrm flush_l1d
TagsNo tags attached.



2023-09-12 15:42

administrator   ~0000976

I have not seen this on EPYC 9354P machines. Will do some more testing on them to see if I can find any relevant logs/messages/etc.


2023-09-14 14:32

reporter   ~0000977

I will be able to do some more debuging tomorrow and on monday. Will report.


2023-09-25 20:08

reporter   ~0000980

I upgraded the server to:
UEFI: 2.11 KAE112O (latest version at the moment)
XCC: 2.13 KAX318X (latest version at the moment)

Kernel: kernel-4.18.0-477.27.1.el8_8.x86_64
Linux firmware: 20230404-114.git2e92a49f.el8_8.alma.1

This is now booting and working as expected.


2023-09-28 12:10

administrator   ~0000981

Great news

Issue History

Date Modified Username Field Change
2023-09-12 10:44 oneuponatime New Issue
2023-09-12 15:42 jonathan Note Added: 0000976
2023-09-14 14:32 oneuponatime Note Added: 0000977
2023-09-25 20:08 oneuponatime Note Added: 0000980
2023-09-28 12:10 alukoshko Note Added: 0000981
2023-09-28 13:01 alukoshko Assigned To => alukoshko
2023-09-28 13:01 alukoshko Status new => resolved
2023-09-28 13:01 alukoshko Resolution open => fixed