View Issue Details

IDProjectCategoryView StatusLast Update
0000037AlmaLinux-8-OTHERpublic2021-07-20 09:37
Reportergrif Assigned Toalukoshko  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Summary0000037: Installing oVirt as a self-hosted engine
DescriptionУстановка ovirt hosted-engine зависает на этапе https://pastebin.com/zvf9T8nP на 20 минут, затем выдает ошибку [ ERROR ] fatal: [localhost]: FAILED! => {"changed" : false, "msg": Host is not up, please check logs, perhaps also on the engine machine"}. При этом vm с engine запущена, но установка не выполнена до конца.
 В логах https://pastebin.com/95GCVeQp видно что скрипт ansible ищет на хосте node02 python2: "2021-03-06 19:42:30 OMST - fatal: [node02.locdomain.local]: FAILED! => {"changed": false, "module_stderr": "/bin/sh: /usr/bin/python2: No such file or directory\n", "module_stdout": "", "msg": "The module failed to execute correctly, you probably need to set the interpreter.\nSee stdout/stderr for the exact error", "rc": 127}"
выбор версии осуществляется по условию:
ansible_python_interpreter : "{{ '/usr/bin/python3'
   if (fc_ver|int > 0 or el_ver|int >= 8)
       else '/usr/bin/python2' }}
а хост имеет следующие значения переменной
  "remote_addr" : "node02.locdomain.local",
      "res" : {
        "changed" : false,
        "ansible_facts" : {
          "el_ver" : "0",
          "fc_ver" : "0"
        },

- name: Detect host operating system
  set_fact:
    el_ver: "{{ ansible_distribution_major_version|int
        if ansible_distribution == 'RedHat' or ansible_distribution == 'CentOS'
        else 0 }}"
    fc_ver: "{{ ansible_distribution_major_version|int
        if ansible_distribution == 'Fedora'
        else 0 }}"

проблему обошел:
alternatives --list
python manual /usr/bin/python3
python3 auto /usr/bin/python3.6
и
cat /etc/redhat-release
CentOS Linux release 8.3.2011

но это кажется не совсем верное решение.
Steps To Reproduceinstall AlmaLinux-8.3-rc-1-x86_64-minimal.iso
configure hostname, static ipv4, /etc/hosts
dnf -y install https://resources.ovirt.org/pub/yum-repo/ovirt-release44.rpm
dnf install ovirt-hosted-engine-setup
hosted-engine deploy
Additional InformationОписание в https://lists.ovirt.org/archives/list/[email protected]/thread/USKOM664QMVW3BGZ3RGCT7FYZAZRDZHS/
TagsNo tags attached.
abrt_hash
URL

Activities

alukoshko

2021-03-09 10:04

developer   ~0000049

I've submitted patch to gerrit.ovirt.org
https://gerrit.ovirt.org/c/ovirt-engine/+/113817

grif

2021-04-14 11:11

reporter   ~0000148

fatal: [node01]: FAILED! => {"changed": false, "module_stderr": "/bin/sh: /usr/bin/python2: No such file or directory\n", "module_stdout": "", "msg": "The module failed to execute correctly, you probably need to set the interpreter.\nSee stdout/stderr for the exact error", "rc": 127}

судя по всему проверка Almalinux гдето еще не проходит

alukoshko

2021-04-14 11:14

developer   ~0000149

That's because patch wasn't merged.
Developers will find another way to handle RHEL-compatible distros.

alukoshko

2021-05-25 09:47

developer   ~0000209

Merged upstream: https://gerrit.ovirt.org/c/ovirt-engine/+/114663

grif

2021-06-11 04:52

reporter   ~0000273

Installing OVirt on AlmaLinux 8.4 failed with a similar error.
TASK [ovirt-host-deploy-vdsm : Install ovirt-hosted-engine-setup package]
 fatal: [node03.mydom.lan]: FAILED! => {"changed": false, "module_stderr": "/bin/sh: /usr/bin/python2: No such file or directory\n", "module_stdout": "", "msg": "The module failed to execute correctly, you probably need to set the interpreter.\nSee stdout/stderr for the exact error", "rc": 127}
 The error occurs on both oVirt-engine 4.4.5 and 4.4.6.

alukoshko

2021-07-14 13:32

developer   ~0000304

Please try release 4.4.7.
It includes the following fix:
BZ 1942023 [RFE] host-deploy: Allow adding non-CentOS hosts based on RHEL

grif

2021-07-16 12:10

reporter   ~0000305

Everything works, thank you! oVirt installed without question. Host is connected to the cluster.

alukoshko

2021-07-20 09:37

developer   ~0000309

Thanks for update!
Closing.

Issue History

Date Modified Username Field Change
2021-03-09 05:33 grif New Issue
2021-03-09 10:04 alukoshko Note Added: 0000049
2021-03-09 10:04 alukoshko Assigned To => alukoshko
2021-03-09 10:04 alukoshko Status new => assigned
2021-04-14 11:11 grif Note Added: 0000148
2021-04-14 11:14 alukoshko Note Added: 0000149
2021-05-25 09:47 alukoshko Note Added: 0000209
2021-06-11 04:52 grif Note Added: 0000273
2021-06-11 04:52 grif File Added: ovirt-host-deploy-ansible-20210610183529-node03-7a0fb2e0-7b9d-451b-a793-15414f74dc39.log
2021-07-14 13:32 alukoshko Note Added: 0000304
2021-07-16 12:10 grif Note Added: 0000305
2021-07-20 09:37 alukoshko Note Added: 0000309
2021-07-20 09:37 alukoshko Status assigned => closed
2021-07-20 09:37 alukoshko Resolution open => fixed