View Issue Details

IDProjectCategoryView StatusLast Update
0000325AlmaLinux-8-OTHERpublic2022-11-18 06:32
Reporternjmetrowsk[email protected] Assigned Toalukoshko  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Summary0000325: KDE 5 Plasma will not update, because Qt5 version provided in AlmaLinx 8.7 is too old a version
DescriptionSample output of issues:

 dnf --enablerepo=epel,powertools group -y install "KDE Plasma Workspaces"
Last metadata expiration check: 2:23:22 ago on Fri 11 Nov 2022 10:03:03 AM MST.
no group 'libreoffice' from environment 'kde-desktop-environment'
No match for group package "rhc"
No match for group package "k3b-extras-freeworld"
No match for group package "hpijs"
Error:
 Problem 1: conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-akonadi-server-21.08.3-1.el8.x86_64
  - nothing provides libQt5Sql.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-akonadi-server-21.08.3-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-akonadi-server-21.08.3-1.el8.x86_64
 Problem 2: conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by plasma-workspace-5.23.3-2.el8.x86_64
 Problem 3: package kmail-21.08.3-1.el8.x86_64 requires libQt5WebEngineCore.so.5()(64bit), but none of the providers can be installed
  - package kmail-21.08.3-1.el8.x86_64 requires libQt5WebEngineWidgets.so.5()(64bit), but none of the providers can be installed
  - package kmail-21.08.3-1.el8.x86_64 requires libQt5WebEngineCore.so.5(Qt_5)(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides libQt5Widgets.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
 Problem 4: package kdeplasma-addons-5.23.3-2.el8.x86_64 requires libQt5WebEngineCore.so.5()(64bit), but none of the providers can be installed
  - package kdeplasma-addons-5.23.3-2.el8.x86_64 requires libQt5WebEngineCore.so.5(Qt_5)(64bit), but none of the providers can be installed
  - package kdeplasma-addons-5.23.3-2.el8.x86_64 requires libQt5WebEngine.so.5()(64bit), but none of the providers can be installed
  - package kdeplasma-addons-5.23.3-2.el8.x86_64 requires libQt5WebEngine.so.5(Qt_5)(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides libQt5Widgets.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by qt5-qtwebengine-5.15.6-1.el8.1.x86_64
 Problem 5: package kmouth-21.08.3-1.el8.x86_64 requires libQt5TextToSpeech.so.5()(64bit), but none of the providers can be installed
  - package kmouth-21.08.3-1.el8.x86_64 requires libQt5TextToSpeech.so.5(Qt_5)(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by qt5-qtspeech-5.15.2-4.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by qt5-qtspeech-5.15.2-4.el8.x86_64
 Problem 6: package plasma-desktop-5.23.3-1.el8.x86_64 requires libtaskmanager.so.6()(64bit), but none of the providers can be installed
  - package plasma-desktop-5.23.3-1.el8.x86_64 requires libnotificationmanager.so.1()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by plasma-workspace-libs-5.23.3-2.el8.x86_64
  - nothing provides libQt5WaylandClient.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by plasma-workspace-libs-5.23.3-2.el8.x86_64
 Problem 7: package sddm-breeze-5.23.3-2.el8.noarch requires plasma-workspace = 5.23.3-2.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by plasma-workspace-5.23.3-2.el8.x86_64
 Problem 8: package kde-print-manager-21.08.3-1.el8.x86_64 requires plasma-workspace, but none of the providers can be installed
  - conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by plasma-workspace-5.23.3-2.el8.x86_64
 Problem 9: package kscreenlocker-5.23.3-1.el8.x86_64 requires libLayerShellQtInterface.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by layer-shell-qt-5.23.3-1.el8.x86_64
  - nothing provides libQt5WaylandClient.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by layer-shell-qt-5.23.3-1.el8.x86_64
 Problem 10: package kwin-5.23.3-1.el8.x86_64 requires kwin-x11 = 5.23.3-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kwin-x11-5.23.3-1.el8.x86_64
 Problem 11: package plasma-discover-5.22.5-2.el8.x86_64 requires libKUserFeedbackCore.so.1()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kuserfeedback-1.0.0-8.el8.x86_64
 Problem 12: package kate-21.12.2-1.el8.x86_64 requires libKUserFeedbackCore.so.1()(64bit), but none of the providers can be installed
  - package kate-21.12.2-1.el8.x86_64 requires libKUserFeedbackWidgets.so.1()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kuserfeedback-1.0.0-8.el8.x86_64
 Problem 13: package spectacle-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 14: package sddm-kcm-5.23.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 15: package okular-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 16: package kwrite-21.12.2-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 17: package kwalletmanager5-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 18: package kscreen-1:5.23.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 19: package kruler-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 20: package korganizer-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 21: package kontact-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 22: package konsole5-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 23: package kmousetool-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 24: package kmenuedit-5.23.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 25: package kmag-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 26: package khotkeys-5.23.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 27: package khelpcenter-1:21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 28: package kgpg-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 29: package kfind-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 30: package keditbookmarks-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 31: package kde-partitionmanager-3.3.1-4.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 32: package kcolorchooser-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 33: package kcharselect-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 34: package kcalc-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 35: package kamera-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 36: package kaddressbook-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 37: package gwenview-1:21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 38: package dolphin-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 39: package bluedevil-5.23.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 40: package akregator-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 41: package plasma-systemmonitor-5.23.3-1.el8.x86_64 requires kf5-kirigami2(x86-64) >= 5.82, but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kirigami2-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kirigami2-5.88.0-1.el8.x86_64
 Problem 42: package plasma-nm-5.23.3-2.el8.x86_64 requires kf5-kirigami2, but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kirigami2-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kirigami2-5.88.0-1.el8.x86_64
 Problem 43: package kinfocenter-5.23.3-1.el8.x86_64 requires kf5-kirigami2(x86-64), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kirigami2-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kirigami2-5.88.0-1.el8.x86_64
 Problem 44: package polkit-kde-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 45: package plasma-thunderbolt-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 46: package plasma-pa-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 47: package plasma-nm-pptp-5.23.3-2.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 48: package plasma-nm-openvpn-5.23.3-2.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 49: package plasma-nm-openswan-5.23.3-2.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 50: package plasma-nm-openconnect-5.23.3-2.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 51: package plasma-nm-l2tp-5.23.3-2.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 52: package plasma-drkonqi-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 53: package plasma-discover-notifier-5.22.5-2.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 54: package plasma-breeze-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 55: package ksshaskpass-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 56: package kf5-baloo-file-5.88.0-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 57: package kdnssd-21.08.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 58: package kdialog-21.08.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 59: package colord-kde-0.5.0-15.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 60: package kf5-akonadi-server-mysql-21.08.3-1.el8.x86_64 requires kf5-akonadi-server(x86-64) = 21.08.3-1.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-akonadi-server-21.08.3-1.el8.x86_64
  - nothing provides libQt5Sql.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-akonadi-server-21.08.3-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-akonadi-server-21.08.3-1.el8.x86_64
 Problem 61: package kde-gtk-config-5.23.3-1.el8.x86_64 requires kde-cli-tools, but none of the providers can be installed
  - package kde-cli-tools-5.23.3-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 62: package kdegraphics-thumbnailers-21.08.3-1.el8.x86_64 requires libKF5KIOCore.so.5()(64bit), but none of the providers can be installed
  - package kf5-kio-core-libs-5.88.0-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 63: package pam-kwallet-5.23.3-1.el8.x86_64 requires kf5-kwallet, but none of the providers can be installed
  - package kf5-kwallet-5.88.0-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
 Problem 64: package kf5-kipi-plugins-21.08.3-1.el8.x86_64 requires kf5-kipi-plugins-libs(x86-64) = 21.08.3-1.el8, but none of the providers can be installed
  - package kf5-kipi-plugins-libs-21.08.3-1.el8.x86_64 requires libKF5XmlGui.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
  - nothing provides qt5-qtbase(x86-64) = 5.15.2 needed by kf5-kxmlgui-5.88.0-1.el8.x86_64
 Problem 65: package plasma-workspace-geolocation-5.23.3-2.el8.x86_64 requires libKF5KIOCore.so.5()(64bit), but none of the providers can be installed
  - package kf5-kio-core-libs-5.88.0-1.el8.x86_64 requires libKF5I18n.so.5()(64bit), but none of the providers can be installed
  - conflicting requests
  - nothing provides libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit) needed by kf5-ki18n-5.88.0-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[email protected]:~#
Steps To Reproduce dnf --enablerepo=epel,powertools group -y install "KDE Plasma Workspaces"
Additional InformationIf you have KDE 5 Plasma installed, then use dnf update --skip-broken when going from AlmaLinux 8.6 to AlamaLinux 8.7
TagsKDE 5 Plsm, Qt5
abrt_hash
URL

Activities

[email protected]

2022-11-15 22:45

reporter   ~0000723

In the end these modules fail because qt5 is newer than the kf5 and KDE provided in the 8.7 update:

kf5-akonadi-server-21.08.3-1.el8.x86_64
kf5-ki18n-5.88.0-1.el8.x86_64
kf5-kirigami2-5.88.0-1.el8.x86_64
kf5-kxmlgui-5.88.0-1.el8.x86_64
kuserfeedback-1.0.0-8.el8.x86_64
kwin-x11-5.23.3-1.el8.x86_64
layer-shell-qt-5.23.3-1.el8.x86_64
plasma-workspace-5.23.3-2.el8.x86_64
plasma-workspace-libs-5.23.3-2.el8.x86_64
qt5-qtspeech-5.15.2-4.el8.x86_64
qt5-qtwebengine-5.15.6-1.el8.1.x86_64

[email protected]

2022-11-16 23:06

reporter   ~0000727

This is the fix, more like a kluge:

dnf --enablerepo=epel,powertools group -y remove "KDE Plasma Workspaces" --enablerepo=epel-testing

dnf --enablerepo=epel,powertools group -y install "KDE Plasma Workspaces" --enablerepo=epel-testing

Upstream did not put all of the KDE modules in the production repo, but put some of them in the test repo

Regardless, that the above commands fixes the problem, it is not an ideal solution. This needs to be fixed.

alukoshko

2022-11-17 12:15

administrator   ~0000728

Hello. It's actually a EPEL issue.

AlmaLinux 8.7 (like RHEL 8.7) has Qt 5.15.3 and KDE packages in EPEL (3rd party repo) are outdated and built with Qt 5.15.2.
Nothing to do on AlmaLinux side. We just have to wait for EPEL to update.

Issue History

Date Modified Username Field Change
2022-11-11 19:54 [email protected] New Issue
2022-11-11 19:54 [email protected] Tag Attached: KDE 5 Plsm
2022-11-11 19:54 [email protected] Tag Attached: Qt5
2022-11-15 22:45 [email protected] Note Added: 0000723
2022-11-16 23:06 [email protected] Note Added: 0000727
2022-11-17 12:15 alukoshko Note Added: 0000728
2022-11-17 12:16 alukoshko Assigned To => alukoshko
2022-11-17 12:16 alukoshko Status new => closed
2022-11-17 12:16 alukoshko Resolution open => no change required