View Issue Details

IDProjectCategoryView StatusLast Update
0000323AlmaLinux-8qt5public2022-11-10 19:25
Reporterbkida Assigned Toalukoshko  
Status closedResolutionno change required 
Summary0000323: qt5 dependency problem after almalinux 8.7 release
DescriptionI cannot upgrade from AL8.6 to 8.7 due to a dependency issue for qt5. Architecture aarch64, but it can apply to everyone (I haven't tested)

Below is an example for qt5-base:
[s2:: ~ ]:$ dnf update qt5-qtbase
Last metadata expiration check: 0:02:10 ago on Thu 10 Nov 2022 08:02:26 PM CET.
 Problem: problem with installed package qt5-qtwebengine-5.15.6-1.el8.1.aarch64
  - package qt5-qtwebengine-5.15.6-1.el8.1.aarch64 requires, but none of the providers can be installed
  - package qt5-qtwebengine-5.15.6-1.el8.1.aarch64 requires qt5-qtbase(aarch-64) = 5.15.2, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.15.3-1.el8.aarch64 and qt5-qtbase-5.15.2-4.el8.aarch64
  - cannot install the best update candidate for package qt5-qtbase-5.15.2-4.el8.aarch64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Sample programs that use qt5: nextcloud-client, keepassxc.
Steps To Reproducednf --refresh update qt5-base qt5-qtbase-gui qt5-qtwebengine qt5-qtgraphicaleffects

TagsNo tags attached.



2022-11-10 19:25

administrator   ~0000715

qt5-qtwebengine is EPEL package.
It should be updated for the new QT in 8.7.

Issue History

Date Modified Username Field Change
2022-11-10 19:18 bkida New Issue
2022-11-10 19:25 alukoshko Note Added: 0000715
2022-11-10 19:25 alukoshko Assigned To => alukoshko
2022-11-10 19:25 alukoshko Status new => closed
2022-11-10 19:25 alukoshko Resolution open => no change required