View Issue Details

IDProjectCategoryView StatusLast Update
0000145AlmaLinux-8kernelpublic2021-11-25 08:43
Reporterkajtzu Assigned Toalukoshko  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platform8 
Summary0000145: add more pci ids for megaraid_sas
DescriptionThanks for adding more megaraid_sas pci ids than what the upstream kernel supports. Would it be possible to add one more?

On Dell R410 (at least) the card shows up as:

01:00.0 RAID bus controller [0104]: LSI Logic / Symbios Logic MegaRAID SAS 1078 [1000:0060] (rev 04)

-> modinfo megaraid_sas does not show a pci id matching 1000:0060
Steps To ReproduceTry booting Alma on an R410 or similar generation of servers
Additional InformationI'll buy a beer to the person fixing it, you just need to come to Helsinki :)
Tagsmegaraidsas
abrt_hash
URL

Activities

alukoshko

2021-11-12 22:56

developer   ~0000380

Hello!
I think the best option is to monitor this repo http://elrepo.reloumirrors.net/testing/el8/x86_64/RPMS/ for megaraid_sas module.
elrepo.org community doing a great job adding hardware support removed from upstream.

P.S. we haven't added any new pci ids to kernel
P.P.S. Helsinki is so nice place. I've been there two times

Kiitos!

toracat

2021-11-13 01:27

reporter   ~0000386

ELRepo's kmod-megaraid_sas supports the device ID [1000:0060].

If you are installing EL 8.5, wait for an updated version (tagged .el8_5) that should be released very soon.

toracat

2021-11-16 20:26

reporter   ~0000394

It is out now:

https://elrepo.org/linux/elrepo/el8/x86_64/RPMS/kmod-megaraid_sas-07.717.02.00-1.el8_5.elrepo.x86_64.rpm

If you need a DVD iso image for the installation, it is available, too:

https://elrepo.org/linux/dud/el8/x86_64/dd-megaraid_sas-07.717.02.00-1.el8_5.elrepo.iso

kajtzu

2021-11-17 07:40

reporter   ~0000398

@toracat thanks for checking, highly appreciated :)

I used the elrepo previously with the distro starting with a c but must have managed to do something silly since I couldn’t get the same .iso to work with kickstart and alma last time I tried. Problem between keyboard and chair I assume.

Issue History

Date Modified Username Field Change
2021-11-11 10:58 kajtzu New Issue
2021-11-11 10:58 kajtzu Tag Attached: megaraidsas
2021-11-12 22:56 alukoshko Note Added: 0000380
2021-11-13 01:27 toracat Note Added: 0000386
2021-11-16 20:26 toracat Note Added: 0000394
2021-11-17 07:40 kajtzu Note Added: 0000398
2021-11-25 08:43 alukoshko Assigned To => alukoshko
2021-11-25 08:43 alukoshko Status new => closed
2021-11-25 08:43 alukoshko Resolution open => no change required