View Issue Details

IDProjectCategoryView StatusLast Update
0000127AlmaLinux-8-OTHERpublic2021-10-19 12:09
Reporterkarelklic Assigned Toalukoshko  
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
OSAlmaLinux 8OS Version8.4 
Summary0000127: AlmaLinux fails to install via virt-install
DescriptionI can set up a CentOS virtual machine using virt-install from the command line, but the same procedure fails with AlmaLinux.
Steps To Reproduce1. Use a typical workstation with fully updated AlmaLinux 8, virt-manager, libvirt, virt-install, and firewalld.

2. Try to install CentOS 8 VM:
sudo virt-install \
    --memory 3072 \
    --vcpus 2 \
    --graphics none \
    --network bridge=virbr0 \
    --os-type=linux \
    --os-variant=centos8 \
    --location http://mirror.centos.org/centos-8/8/BaseOS/x86_64/os/ \
    --noreboot \
    --hvm \
    --wait -1 \
    --extra-args "console=ttyS0,115200"

3. See that the textual Anaconda installer starts after a few minutes time, allowing to proceed with the installation.

4. Now let's try to install AlmaLinux 8 VM with equivalent arguments:
sudo virt-install \
    --memory 3072 \
    --vcpus 2 \
    --graphics none \
    --network bridge=virbr0 \
    --os-type=linux \
    --os-variant=almalinux8 \
    --location https://repo.almalinux.org/almalinux/8/BaseOS/x86_64/os/ \
    --noreboot \
    --hvm \
    --wait -1 \
    --extra-args "console=ttyS0,115200"

5. See that the VM startup is stuck and the Anaconda installer never starts:
[ OK ] Reached target Basic System.
[ 12.114346] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 12.117493] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 12.118667] 8021q: adding VLAN 0 to HW filter on device enp1s0
[ 12.122468] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 12.125027] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[ 12.319085] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[ 160.556064] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 161.187649] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 161.781877] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 162.376911] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 162.974903] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 163.568660] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 164.179282] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 164.777730] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 165.378744] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 165.996595] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 166.612907] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 167.230635] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 167.846792] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 168.446548] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 169.059694] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 169.668433] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 170.264853] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 170.887612] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
[ 171.482921] dracut-initqueue[981]: Warning: dracut-initqueue timeout - starting timeout scripts
Additional InformationThe kickstart repo (https://repo.almalinux.org/almalinux/8/BaseOS/x86_64/kickstart/) fails as well.

The older 8.3 repo (https://repo.almalinux.org/almalinux/8.3/BaseOS/x86_64/os/) fails as well.

I tried to change the --os-variant argument and it has no effect (CentOS 8 installer starts fine with --os-variant almalinux8).
TagsNo tags attached.
abrt_hash
URL

Activities

sej7278

2021-10-14 22:47

reporter   ~0000346

Looking at the process list, the only difference i can find between a working centos8 and non-working alma8 is the centos commandline includes:

inst.repo=http://mirror.centos.org/centos-8/8/BaseOS/x86_64/os/

looks like the following is missing from the osinfo-db entry:

    <kernel-url-argument>inst.repo</kernel-url-argument>

or something like that - the above is found in rhel/fedora, i think centos bakes it into the initrd or something, lots of chat here: https://github.com/coreos/fedora-coreos-tracker/issues/221

sej7278

2021-10-15 09:01

reporter   ~0000348

if you turn on virt-install --debug you can see centos has inst.repo injected (by osinfo-db?):

    <cmdline>console=ttyS0,115200 inst.repo=http://mirror.centos.org/centos-8/8/BaseOS/x86_64/os/</cmdline>

but almalinux only has what you've set:

    <cmdline>console=ttyS0,115200</cmdline>

as a workaround, inject the inst.repo yourself:

    --extra-args "console=ttyS0,115200 inst.repo=http://repo.almalinux.org/almalinux/8/BaseOS/x86_64/os/"

but this needs fixing by the osinfo-db folks, although not really sure where as the centos and almalinux xml seems to use a totally different setup:

https://gitlab.com/libosinfo/osinfo-db/-/blob/master/data/os/almalinux.org/almalinux-8.xml.in

https://gitlab.com/libosinfo/osinfo-db/-/blob/master/data/os/centos.org/centos-8.xml.in

possibly something needs changing here:

https://gitlab.com/libosinfo/osinfo-db/-/blob/master/data/install-script/redhat.com/rhel-kickstart-jeos.xml.in

alukoshko

2021-10-15 12:15

developer   ~0000350

Thank you for report and for updates.
Could you please test the same with updated osinfo-sb from 8.5 beta?
https://repo.almalinux.org/almalinux/8.5-beta/AppStream/x86_64/os/Packages/osinfo-db-20210809-1.el8.noarch.rpm

karelklic

2021-10-15 13:39

reporter   ~0000351

sej7278, thank you for figuring out the workaround, adding inst.repo to extra-args works great!

alukoshko, the osinfo-db-20210809-1 package doesn't solve the issue for me. The workaround is still required.

sej7278

2021-10-15 15:26

reporter   ~0000352

yeah, its not fixed in git and i'm running a debian host anyway, so the 8.5 beta rpm isn't going to include the fix as its not been written yet.

not really sure what needs to be fixed in the osinfo-db code though otherwise i'd report it to them.

alukoshko

2021-10-19 12:09

developer   ~0000355

The problem is on virt-install side.
PR to upstream: https://github.com/virt-manager/virt-manager/pull/314
Also released virt-install-2.2.1-4.el8.alma to fix this issue.
Thanks everyone.

Issue History

Date Modified Username Field Change
2021-09-20 14:38 karelklic New Issue
2021-10-14 22:47 sej7278 Note Added: 0000346
2021-10-15 09:01 sej7278 Note Added: 0000348
2021-10-15 12:15 alukoshko Note Added: 0000350
2021-10-15 13:39 karelklic Note Added: 0000351
2021-10-15 15:26 sej7278 Note Added: 0000352
2021-10-19 12:09 alukoshko Note Added: 0000355
2021-10-19 12:09 alukoshko Assigned To => alukoshko
2021-10-19 12:09 alukoshko Status new => resolved
2021-10-19 12:09 alukoshko Resolution open => fixed