View Issue Details

IDProjectCategoryView StatusLast Update
0000109AlmaLinux-8-OTHERpublic2021-09-13 12:43
Reportermetal4lyf Assigned Toalukoshko  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Summary0000109: Can't offline install
DescriptionWhen attempting to install using the AlmaLinux dvd iso on an offline system, there does not seem to be a way to enable the AppStream repo on the boot media.
This is a prerequisite for us to migrate our application from CentOS as there is not always a network connection at the time of install.

Performing a graphical install using the CentOS installer, when offline we are presented with a 3rd option "auto-detected source" on the Installation Source menu. This is missing from the AlmaLinux installer.

Ultimately we want to be able to use our existing kickstart configuration, which has this line (working with the CentOS dvd iso):
repo --name=AppStream --baseurl=file:///run/install/repo/AppStream

Is there a different way to install from the boot media that we're missing?
Steps To Reproduce1. Burn dvd iso to boot media
2. Unplug network cable
3. Boot from iso and launch graphical installation, click through language selection
4. Observe "Error setting up base repository"
5. Select "Installation Source" and observe that you're stuck
TagsNo tags attached.
abrt_hash
URL

Activities

metal4lyf

2021-06-29 16:08

reporter   ~0000292

This may be an issue with how I was burning the image. The Rocky team suggested burning in DD mode (I was using ISO mode with Rufus) and that resolved it for the Rocky dvd image. I haven't verified with Alma yet but if you're using a hybrid image then it's probably the same issue.

metal4lyf

2021-07-16 18:06

reporter   ~0000307

I believe the reason burning with "ISO mode" no longer works with RH8.4 is this: https://github.com/rhinstaller/anaconda/commit/84529204fe02300b9829da41099a8254dc2a1c54

(We need to do so because corporate workstations run Windows and we need read/write access to the boot media on Windows to update kickstarts etc.).

I found a workaround that involves starting http servers in the anaconda boot environment to serve the attached repositories in `/run/install/repo/`.

alukoshko

2021-09-13 12:43

developer   ~0000331

Hello. You're right.
DD mode should be used.
Thanks for update.

Issue History

Date Modified Username Field Change
2021-06-28 19:01 metal4lyf New Issue
2021-06-29 09:04 alukoshko Assigned To => alukoshko
2021-06-29 09:04 alukoshko Status new => assigned
2021-06-29 16:08 metal4lyf Note Added: 0000292
2021-07-16 18:06 metal4lyf Note Added: 0000307
2021-09-13 12:43 alukoshko Note Added: 0000331
2021-09-13 12:43 alukoshko Status assigned => closed
2021-09-13 12:43 alukoshko Resolution open => fixed