View Issue Details

IDProjectCategoryView StatusLast Update
0000102AlmaLinux-8NetworkManagerpublic2022-04-26 08:50
Reporteradontz Assigned Tolkhn  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAWSOSAlmaLinuxOS Version8.4
Fixed in Version8.4 
Summary0000102: Incorrect SELinux label on /etc/sysconfig/network-scripts/ifcfg-eth0
DescriptionIncorrect SELinux label on

    /etc/sysconfig/network-scripts/ifcfg-eth0

which is "system_u:object_r:unlabeled_t:s0" instead of "system_u:object_r:net_conf_t:s0" renders nmcli unusable.
Try to update connection configuration logs similar error message

NetworkManager[783]: <info> [1624210442.3384] audit: op="connection-update" uuid="5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03" name="eth0" args="ipv4.dns-search,connection.timestamp" pid=9325 uid=0 result="fail" reason="failed to update connection: Could not open file '/etc/sysconfig/network-scripts/ifcfg-eth0' for writing: Permission denied"
Steps To ReproduceExecute

    nmcli connection modify "eth0" ipv4.dns-search 'example.com'

on a a fresh AWS image.
Additional InformationExecuting

    chcon -t net_conf_t /etc/sysconfig/network-scripts/ifcfg*

completely fixes the problem.
TagsNo tags attached.
abrt_hash
URL

Activities

alukoshko

2021-06-30 18:58

administrator   ~0000295

Hello and thank you! Nice catch.
We are investigating it.

ezamriy

2021-07-05 21:22

administrator   ~0000298

The problem is confirmed. I've created a GitHub issue https://github.com/AlmaLinux/cloud-images/issues/23 for it and wrote up my investigation results. We need to change our build pipeline to avoid Amazon's vmimport execution.

lkhn

2022-04-26 08:50

developer   ~0000549

Fixed by: https://github.com/AlmaLinux/cloud-images/commit/37958232da8f387f4bf5bb5ecd65e006b9eb71cb

Issue History

Date Modified Username Field Change
2021-06-20 17:53 adontz New Issue
2021-06-30 18:46 alukoshko Assigned To => ezamriy
2021-06-30 18:46 alukoshko Status new => assigned
2021-06-30 18:58 alukoshko Note Added: 0000295
2021-07-05 21:22 ezamriy Note Added: 0000298
2022-04-26 08:50 lkhn Assigned To ezamriy => lkhn
2022-04-26 08:50 lkhn Status assigned => resolved
2022-04-26 08:50 lkhn Resolution open => fixed
2022-04-26 08:50 lkhn Fixed in Version => 8.4
2022-04-26 08:50 lkhn Note Added: 0000549