View Issue Details

IDProjectCategoryView StatusLast Update
0000049AlmaLinux-8WALinuxAgentpublic2021-04-07 15:42
Reporteralmalinux4all Assigned Toalukoshko  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMS AzureOSAlmaLinuxOS Version8.3
Summary0000049: WALinuxAgent gives the following message on boot: WARNING ExtHandler Unable to load distro implementation for almalinux. Using d
DescriptionWe created an AlmaLinux image for Azure, using the exact same config we do for CentOS. In Azure, any linux instance must run the Azure Linux Agent. This package exist in AlmaLinux as well, but it gives the following warning on console:

2021-03-31T10:23:10.420170Z WARNING ExtHandler Unable to load distro implementation for almalinux. Using default distro implementation instead.

# rpm -q WALinuxAgent
WALinuxAgent-2.2.46-8.el8.noarch

Regards,
Steps To ReproduceCreate AlmaLinux Azure image
Make sure Azure Linux Agent WALinuxAgent-2.2.46-8.el8.noarch is installed and started during boot
Check also that Azure Linux Agent uses cloud-init as provisioning agent

# cat /etc/waagent.conf
[...]
Provisioning.Agent=cloud-init
[...]

Thanks and regards
TagsNo tags attached.
abrt_hash
URL

Activities

almalinux4all

2021-03-31 10:53

reporter   ~0000090

trying to find out which file has such warning text available, I did the following:

# grep -r "Using default distro implementation instead" /lib/
Binary file /lib/python3.6/site-packages/azurelinuxagent/common/osutil/__pycache__/factory.cpython-36.opt-1.pyc matches
Binary file /lib/python3.6/site-packages/azurelinuxagent/common/osutil/__pycache__/factory.cpython-36.pyc matches


looking in /lib/python3.6/site-packages/azurelinuxagent/common/osutil/__pycache__/ folder, there are a lot of *.cpython-36.opt-1.pyc, but not for almalinux:

# ls -al /lib/python3.6/site-packages/azurelinuxagent/common/osutil/__pycache__/
total 376
drwxr-xr-x. 2 root root 4096 Mar 31 09:45 .
drwxr-xr-x. 3 root root 4096 Mar 31 09:45 ..
-rw-r--r--. 2 root root 1628 Nov 5 18:32 alpine.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 1628 Nov 5 18:32 alpine.cpython-36.pyc
-rw-r--r--. 2 root root 2364 Nov 5 18:32 arch.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 2364 Nov 5 18:32 arch.cpython-36.pyc
-rw-r--r--. 2 root root 13120 Nov 5 18:32 bigip.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 13120 Nov 5 18:32 bigip.cpython-36.pyc
-rw-r--r--. 2 root root 3651 Nov 5 18:32 clearlinux.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 3651 Nov 5 18:32 clearlinux.cpython-36.pyc
-rw-r--r--. 2 root root 2944 Nov 5 18:32 coreos.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 2944 Nov 5 18:32 coreos.cpython-36.pyc
-rw-r--r--. 2 root root 3210 Nov 5 18:32 debian.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 3210 Nov 5 18:32 debian.cpython-36.pyc
-rw-r--r--. 2 root root 45485 Nov 5 18:32 default.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 45485 Nov 5 18:32 default.cpython-36.pyc
-rw-r--r--. 2 root root 2731 Nov 5 18:32 factory.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 2731 Nov 5 18:32 factory.cpython-36.pyc
-rw-r--r--. 2 root root 21365 Nov 5 18:32 freebsd.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 21365 Nov 5 18:32 freebsd.cpython-36.pyc
-rw-r--r--. 2 root root 7623 Nov 5 18:32 gaia.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 7623 Nov 5 18:32 gaia.cpython-36.pyc
-rw-r--r--. 2 root root 185 Nov 5 18:32 __init__.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 185 Nov 5 18:32 __init__.cpython-36.pyc
-rw-r--r--. 2 root root 2937 Nov 5 18:32 iosxe.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 2937 Nov 5 18:32 iosxe.cpython-36.pyc
-rw-r--r--. 2 root root 5901 Nov 5 18:32 nsbsd.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 5901 Nov 5 18:32 nsbsd.cpython-36.pyc
-rw-r--r--. 2 root root 12531 Nov 5 18:32 openbsd.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 12531 Nov 5 18:32 openbsd.cpython-36.pyc
-rw-r--r--. 2 root root 5971 Nov 5 18:32 openwrt.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 5971 Nov 5 18:32 openwrt.cpython-36.pyc
-rw-r--r--. 2 root root 5874 Nov 5 18:32 redhat.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 5874 Nov 5 18:32 redhat.cpython-36.pyc
-rw-r--r--. 2 root root 5104 Nov 5 18:32 suse.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 5104 Nov 5 18:32 suse.cpython-36.pyc
-rw-r--r--. 2 root root 6479 Nov 5 18:32 ubuntu.cpython-36.opt-1.pyc
-rw-r--r--. 2 root root 6479 Nov 5 18:32 ubuntu.cpython-36.pyc

I am not sure this is related to WALinuxAgent anymore, but the /lib/python3.6/site-packages/azurelinuxagent/common/osutil/__pycache__/factory.cpython-36.opt-1.pyc file is part of WALinuxAgent package:

# rpm -qf /lib/python3.6/site-packages/azurelinuxagent/common/osutil/__pycache__/factory.cpython-36.opt-1.pyc
WALinuxAgent-2.2.46-8.el8.noarch

almalinux4all

2021-03-31 10:56

reporter   ~0000091

The Azure image works good, so this far, this issue looks more like a cosmetic issue...

alukoshko

2021-04-01 06:27

developer   ~0000099

Hello and thanks for report.
Looks like we have to patch WALinuxAgent in our repo and make pull request to https://github.com/Azure/WALinuxAgent
I'll keep this bug open.

almalinux4all

2021-04-01 08:29

reporter   ~0000100

Indeed. Thank you so much for looking into this.

alukoshko

2021-04-07 15:41

developer   ~0000132

WALinuxAgent-2.2.46-8.el8.alma was released with this bug fixed
We've also created pull request: https://github.com/Azure/WALinuxAgent/pull/2219

Issue History

Date Modified Username Field Change
2021-03-31 10:38 almalinux4all New Issue
2021-03-31 10:53 almalinux4all Note Added: 0000090
2021-03-31 10:56 almalinux4all Note Added: 0000091
2021-03-31 18:20 alukoshko Assigned To => alukoshko
2021-03-31 18:20 alukoshko Status new => assigned
2021-04-01 06:27 alukoshko Note Added: 0000099
2021-04-01 08:29 almalinux4all Note Added: 0000100
2021-04-07 15:41 alukoshko Note Added: 0000132
2021-04-07 15:42 alukoshko Status assigned => resolved
2021-04-07 15:42 alukoshko Resolution open => fixed