View Issue Details

IDProjectCategoryView StatusLast Update
0000329AlmaLinux-8-OTHERpublic2022-11-18 02:03
Reporterbugfood Assigned Toelkhan  
Status resolvedResolutionfixed 
Summary0000329: AlmaLinux 8.7 AMI EBS snapshot unreadable -- cannot copy AMI

I am attempting to make a local copy of the AlmaLinux 8.7 us-east-1 x86_64 AMI into our own AWS account. This issue probably applies to the AMIs for other reasons and architectures, though I have not tested any other AMIs.

The motivation to do this is to provide resiliency against future removal of the public AMI (see

I am following the process documented by AWS:

I am using the AlmaLinux 8.7 AMI list published here:

The observed error from AWS is:
Failed to copy ami-0924610ece26e5e7b
You do not have permission to access the storage of this ami

Steps To Reproduce1. Log into AWS using a third party account (probably any account that is _not_ the account which owns the AlmaLinux AMIs).
2. Go to
3. Click "Copy AMI".
Additional InformationI searched the web for the text of the error message; this appears to be because the AMI's underlying EBS snapshot does not have public readability. This appears to be a semi-common issue for other projects in the same situation.

This CoreOS ticket has the best information I have seen:

Some other issues of the same nature from other projects are:
Tagsami, aws, cloud



2022-11-15 20:09

reporter   ~0000722

Typo in my description above: "AMIs for other reasons" should be "AMIs for other regions".


2022-11-16 15:46

developer   ~0000724

Last edited: 2022-11-16 15:49

Dear Corey,

Many thanks for such a wonderful report and contribution. We made public every snapshot of the AMI and will add this feature to our AMI mirror tool for the future releases. Please, check whether you can successfully do the copy operation.


2022-11-16 18:23

reporter   ~0000725

You're welcome for the report, and thank you for fixing this. I re-tried the operation and the copy succeeded this time. I haven't yet tried to use the copy, but should be able to later today. Feel free to close the ticket, though--it should be good.


2022-11-16 20:05

reporter   ~0000726

I tested an instance built using our copy of ami-0924610ece26e5e7b, and that worked fine. All seems well. Thanks again.


2022-11-18 02:02

developer   ~0000732

Dear Corey,

Thanks again for the reporting!

Issue History

Date Modified Username Field Change
2022-11-15 18:16 bugfood New Issue
2022-11-15 18:36 elkhan Assigned To => elkhan
2022-11-15 18:36 elkhan Status new => assigned
2022-11-15 20:09 bugfood Note Added: 0000722
2022-11-16 15:46 elkhan Note Added: 0000724
2022-11-16 15:49 elkhan Note Edited: 0000724
2022-11-16 18:23 bugfood Note Added: 0000725
2022-11-16 20:05 bugfood Note Added: 0000726
2022-11-18 02:02 elkhan Note Added: 0000732
2022-11-18 02:02 elkhan Status assigned => resolved
2022-11-18 02:02 elkhan Resolution open => fixed
2022-11-18 02:03 elkhan Tag Attached: ami
2022-11-18 02:03 elkhan Tag Attached: aws
2022-11-18 02:03 elkhan Tag Attached: cloud