View Issue Details

IDProjectCategoryView StatusLast Update
0000278AlmaLinux-8phppublic2022-09-01 13:25
Reporterap8 Assigned Toalukoshko  
PriorityhighSeveritymajorReproducibilityalways
Status feedbackResolutionreopened 
Platformx86_64OSAlmaLinuxOS Version8.6
Summary0000278: After enabling the dnf modules nginx:1.20 and php:7.4, a conflict arises which says that php:7.4 requires nginx:1.14
DescriptionThe exact error message is:

```
Modular dependency problems:

 Problem: module php:7.4:8060020220701053012:a4870ff1.x86_64 requires module(nginx:1.14), but none of the providers can be installed
  - module nginx:1.14:8030020210419100506:f8e95b4e.x86_64 conflicts with module(nginx:1.20) provided by nginx:1.20:8060020220421131139:9edba152.x86_64
  - module nginx:1.20:8060020220421131139:9edba152.x86_64 conflicts with module(nginx:1.14) provided by nginx:1.14:8030020210419100506:f8e95b4e.x86_64
  - conflicting requests
```

The issue does NOT seem to affect RHEL 8.6 nor RockyLinux 8.6, while it occurs in AlmaLinux 8.6.
I noticed this for the first time on July 3rd (on July 2nd I had applied several updates to the OS).
Steps To ReproduceIn a clean VM/container:

* `dnf module switch-to nginx:1.20`
* `dnf module switch-to php:7.4`
TagsNo tags attached.
abrt_hash
URL

Activities

eabdullin

2022-07-08 05:36

reporter   ~0000632

Thank you for the report. The issue is fixed!

ap8

2022-07-08 09:57

reporter   ~0000633

Thank you very much for fixing it so promptly, all my servers were patched successfully this morning. Cheers!

ap8

2022-08-27 09:25

reporter   ~0000682

The issue is happening again with newer versions. Still, it affects only AlmaLinux and not RHEL.

```
Modular dependency problems:

 Problem: module php:7.4:8060020220824162156:a4870ff1.aarch64 requires module(nginx:1.14), but none of the providers can be installed
  - module nginx:1.14:8040020210504103136:f8e95b4e.aarch64 conflicts with module(nginx:1.20) provided by nginx:1.20:8060020220421131149:9edba152.aarch64
  - module nginx:1.20:8060020220421131149:9edba152.aarch64 conflicts with module(nginx:1.14) provided by nginx:1.14:8040020210504103136:f8e95b4e.aarch64
  - conflicting requests
```

alukoshko

2022-08-29 11:24

administrator   ~0000684

Thank for report, we see the problem and will fix soon.

Issue History

Date Modified Username Field Change
2022-07-06 21:27 ap8 New Issue
2022-07-08 05:36 eabdullin Note Added: 0000632
2022-07-08 09:57 ap8 Note Added: 0000633
2022-07-08 10:03 lkhn Assigned To => lkhn
2022-07-08 10:03 lkhn Status new => resolved
2022-07-08 10:03 lkhn Resolution open => fixed
2022-08-27 09:25 ap8 Status resolved => feedback
2022-08-27 09:25 ap8 Resolution fixed => reopened
2022-08-27 09:25 ap8 Note Added: 0000682
2022-08-29 11:24 alukoshko Note Added: 0000684
2022-09-01 13:25 lkhn Assigned To lkhn => alukoshko